MySAU Portal Login Issues
Incident Report for Spring Arbor University
Resolved
Users are now able to log into the MySAU Portal.
Posted Oct 21, 2016 - 13:57 EDT
Identified
While login issues are being resolved, email is available at https://outlook.office365.com/arbor.edu and Blackboard is available at https://sauonline.arbor.edu. To be notified when the issues are resolved, click on the "Subscribe" link above.
Posted Oct 21, 2016 - 13:47 EDT
Investigating
Users cannot currently log into the MySAU portal.
Posted Oct 21, 2016 - 13:24 EDT