Network disruption in Dietzman Hall
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 08, 2017 - 15:12 EST
Monitoring
Network service has bee restored in Dietzman Hall
Posted about 1 month ago. Nov 08, 2017 - 12:23 EST
Investigating
We are currently investigation a Network disruption in Dietzman Hall
Posted about 1 month ago. Nov 08, 2017 - 12:07 EST