Access databases are unavailable
Incident Report for Spring Arbor University
Resolved
The Student Support Access Database should be working as normal
Posted Jul 14, 2017 - 11:44 EDT
Investigating
Access databases are currently unavailable. Information Services staff are investigating
Posted Jul 14, 2017 - 11:10 EDT