MySAU login issues and printing problems
Incident Report for Spring Arbor University
Resolved
The issues with the portal, CARS, printing and network drives are resolved. Information Services staff will continue to monitor for issues over the weekend. Thank you for your patience.
Posted Jun 09, 2017 - 16:38 EDT
Investigating
We are currently experiencing difficulting printing, signing into the MySAU Portal, and accessing network shared drives. Information Services staff is investigating
Posted Jun 09, 2017 - 09:10 EDT