CARS and MySAU slowness
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 15, 2017 - 09:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Nov 14, 2017 - 09:47 EST
Investigating
CARS and the MySAU portal are currently experiencing performance issues.
Posted about 1 month ago. Nov 14, 2017 - 08:54 EST