Users Unable to Log into CARS
Incident Report for Spring Arbor University
Resolved
CARS is fully operational.
Posted Nov 10, 2017 - 12:40 EST
Monitoring
CARS is back up and working. We are monitoring it
Posted Nov 10, 2017 - 09:15 EST
Investigating
CARS is currently down for all users. Information Services is investigating the issue.
Posted Nov 10, 2017 - 08:23 EST