Network issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Oct 21, 2017 - 17:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2017 - 07:08 EDT
Investigating
Users outside of the SAU Main Campus network are currently unable to log into SAU services. Information Services staff are investigating.
Posted Oct 18, 2017 - 06:44 EDT