Merit Internet Service Service Issue
Incident Report for Spring Arbor University
Resolved
From Merit:

2017-03-17 03:02: Network engineering has fixed the issue. Network engineering has permanently moved traffic to better balance the network traffic when there is a high incidence of simultaneous streaming of popular events such as the NCAA tournament that is occuring this month:)
2017-03-16 17:35: Network engineering are working to relieve congestion. Another update will be sent when available.
Posted Mar 17, 2017 - 07:12 EDT
Identified
From Merit: Network engineering are working to relieve congestion. Another update will be sent when available.
Posted Mar 16, 2017 - 17:38 EDT
Investigating
Description:
Members may be experiencing slow internet speeds with Merit Internet Service.

Comment:
We are seeing higher than normal traffic from our Chicago Peering. Network Engineers are investigating.
Posted Mar 16, 2017 - 14:34 EDT