Scheduled maintenance
Incident Report for Spring Arbor University
Resolved
Maintenance is completed.
Posted Jul 24, 2017 - 23:05 EDT
Identified
All internet access, WiFi, and phones will be impacted tonight (Monday, July 24th) from 11:00 PM to 11:30 PM. The SAU portal will not be available off of campus during this time, but will still be available on campus and at remote sites.
Posted Jul 24, 2017 - 16:27 EDT