Main Campus Network Outage
Incident Report for Spring Arbor University
Resolved
Issue is resolved and connectivity is restored.
Posted Jan 14, 2018 - 15:16 EST
Investigating
Network outage and SAU Main Campus. Information Services is investigating the issue.
Posted Jan 14, 2018 - 15:03 EST