Netflix Outage
Incident Report for Spring Arbor University
Resolved
The issue is resolved. If you are still having issues accessing Netflix, please clear your cache and cookies from the browser you are using.
Posted Jan 19, 2018 - 15:15 EST
Investigating
Netflix website is currently being blocked. Information services is currently working with DNS filter to locate the issue.
Posted Jan 19, 2018 - 15:04 EST