Scheduled maintenance
Incident Report for Spring Arbor University
Resolved
Maintenance has been completed
Posted Jul 18, 2017 - 08:46 EDT
Monitoring
Various services will be impacted by maintenance tonight. The SAU Portal and Access databases may go offline intermittently from 11:15 PM to 1:00 AM.
Posted Jul 17, 2017 - 14:13 EDT