MySAU Portal Down
Incident Report for Spring Arbor University
Resolved
The MySAU portal is back online.
Posted Jan 19, 2018 - 16:09 EST
Investigating
MySAU Portal is currently down. Outlook, Blackboard, and Box still accessible by going directly to website.
Posted Jan 19, 2018 - 16:04 EST