Jenzabar CARS / CX is currently unavailable
Incident Report for Spring Arbor University
Resolved
CARS / Jenzabar are fully operational
Posted Nov 21, 2016 - 08:53 EST
Investigating
We are investigating the issue and will post here as updates are available.
Posted Nov 21, 2016 - 08:23 EST