Workspace Availability
Incident Report for Spring Arbor University
Resolved
Workplace is now working correctly for remote users.
Posted Feb 27, 2017 - 14:43 EST
Identified
Following the Firewall Migration, Workspace is unavailable. SAU and Merit staff continue to work to resolve this issue.
Posted Feb 26, 2017 - 08:27 EST