Phones - Calling in and outbound unavailable
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 3 months ago. May 30, 2019 - 14:07 EDT
Monitoring
In and outbound calling is available again. We will continue to monitor the situation for further connection issues.

Thank you for your patience!
Posted 3 months ago. May 30, 2019 - 11:56 EDT
Update
TelNet Worldwide is currently experiencing a temporary service impairment. We are in the process of isolating the event and taking immediate corrective action. We extend our apologies for any inconvenience this interruption may cause your organization and thank you for your patience.
Posted 3 months ago. May 30, 2019 - 11:32 EDT
Investigating
Currently, all of Spring Arbor University in and outbound calling is unavailable. We are working to resolve the issue.
Posted 3 months ago. May 30, 2019 - 10:55 EDT
This incident affected: Voice Phone System.