CARS: degraded performance
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Nov 01, 2018 - 12:40 EDT
Identified
CARS is currently offline, access is expected to be restored in the next 10 minutes.
Posted Nov 01, 2018 - 12:30 EDT
Investigating
Information Technology is investigating performance issues with CARS.
Posted Nov 01, 2018 - 12:07 EDT