Main campus internet: degraded performance
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 4 months ago. May 01, 2019 - 14:56 EDT
Monitoring
A fix is in place and IT is monitoring for more issues.
Posted 4 months ago. May 01, 2019 - 14:47 EDT
Investigating
IT is investigating degraded internet in several buildings on SAU's main campus.
Posted 4 months ago. May 01, 2019 - 14:31 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).