Login issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 10:54 EDT
Investigating
SAU IT is investigating a login issue affecting most SAU sites.
Posted Jul 30, 2020 - 10:52 EDT
This incident affected: Login services.