Campus phone system outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 08:51 EDT
Identified
Outbound and inbound phone lines are only intermittently available on campus. Our phone provider has reported and is experiencing an outage, and is working to restore service as quickly as possible.
Posted Jul 20, 2020 - 13:39 EDT
This incident affected: Voice Phone System.