Remote site networks
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 11 days ago. Aug 07, 2019 - 10:28 EDT
Identified
Information technology is investigating an issue with connectivity to some of SAU's remote campuses.
Posted 11 days ago. Aug 07, 2019 - 09:19 EDT