Campus Safety house network
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Sep 11, 2019 - 15:16 EDT
Identified
IT is investigating a power issue that has taken the campus safety house offline.
Posted Sep 11, 2019 - 15:03 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).