Outlook Desktop Application Outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 27, 2019 - 11:22 EST
Monitoring
Email application issue appears to be resolved. We are monitoring the situation to confirm the issue is closed.
Posted 5 months ago. Feb 27, 2019 - 09:10 EST
Investigating
We are currently investigating an outage with the outlook desktop application. The online email application accessible through the portal is still functioning. We will update as we determine cause.
Posted 5 months ago. Feb 27, 2019 - 08:14 EST
This incident affected: Email & Calendar (Office 365).