Degraded performance: khouse internet
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 06, 2019 - 21:36 EST
Identified
IT has identified a network outage affecting two k-houses, we are currently investigating.
Posted about 2 months ago. Feb 06, 2019 - 17:56 EST