Vistapoint issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 23:38 EDT
Identified
SAU IT has identified a problem with Vistapoint and Vistapoint is currently offline. This issue cannot be resolved until after business hours today.
Posted Oct 12, 2020 - 09:34 EDT
This incident affected: Voice Phone System.