Lowell Hall Network outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Sep 09, 2018 - 16:12 EDT
Monitoring
Information Technology identified an outage and has already restored services in Lowell Hall. Service is restored, but we are monitoring for additional problems.
Posted Sep 09, 2018 - 13:29 EDT