SAFMC Network
Incident Report for Spring Arbor University
Resolved
Issue is related to power maintenance in the SAFMC building.
Posted Oct 05, 2020 - 15:40 EDT
Identified
SAU IT is investigating a network outage in the SAFMC building.
Posted Oct 05, 2020 - 10:44 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).