SAU phone systems
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 15:56 EDT
Monitoring
Our phone provider is currently reporting large outages across the state of Michigan, but as of yet SAU has not been affected. If we notice a problem we will provide updates here.
Posted Apr 23, 2020 - 09:48 EDT
This incident affected: Voice Phone System.