MySAU and Blackboard - partial outage off campus
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted May 17, 2018 - 23:26 EDT
Identified
Information Services is working with a vendor to restore public service for MySAU and Blackboard. The site is up and running off of campus, but will only load about 75% of the time depending on your location. Try refreshing your webpage if you are having trouble loading the site. Service is expected to be completely restored by late morning.
Posted May 17, 2018 - 09:47 EDT