Kalamazoo site: Power issues
Incident Report for Spring Arbor University
Resolved
Power has been restored.
Posted 16 days ago. Apr 02, 2019 - 16:47 EDT
Monitoring
Information services is investigating power issues at the Kalamazoo site that may lead to a loss of connectivity with network and phones.
Posted 16 days ago. Apr 02, 2019 - 16:25 EDT
This incident affected: Kalamazoo Site (Internet Connectivity).