Box: degraded service
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 03, 2019 - 13:49 EDT
Monitoring
Box is experiencing degraded performance that may make it inaccessible. Box is aware of the problem and actively working to resolve it.
Posted 3 months ago. Apr 03, 2019 - 13:30 EDT
This incident affected: Box (Box Sync, Box Website).