Outlook sign in problems
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted May 14, 2020 - 07:52 EDT
Update
Microsoft has announced the issue is on their end and that this issue is affecting other organizations, IT is working with Microsoft to get an estimate on how long this outage will last. Updates will be posted here.
Posted May 13, 2020 - 14:02 EDT
Identified
IT is investigating a partial outage with logging into Outlook on the web.
Posted May 13, 2020 - 13:30 EDT
This incident affected: Login services.