Campus internet
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 17:02 EST
Identified
Merit Networks is reporting internet issues across the state of Michigan. We have noticed higher than normal latency and slow internet on main campus as a result of this.
Posted Nov 13, 2019 - 13:53 EST
This incident affected: Spring Arbor Campus (Internet Connectivity).