CARS and System Outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted May 08, 2020 - 13:24 EDT
Investigating
We are currently investigating an outage on CARS and some other services including some on MySAU.
Posted May 08, 2020 - 10:54 EDT
This incident affected: CARS / MySAU Portal (MySAU Portal, CARS / Jenzabar CX).