Salesforce: Major outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 3 months ago. May 20, 2019 - 08:37 EDT
Monitoring
Salesforce is experiencing a major system outage, and their website is offline. We are working with them to get more information on their outage, and we will post any information we find here. Their status is available at trust.salesforce.com.
Posted 3 months ago. May 17, 2019 - 13:18 EDT
This incident affected: Salesforce NA37.