Some Services are not available
Incident Report for Spring Arbor University
Postmortem

There was a massive DDoS (Distributed Denial of Service) attack this morning against Dyn, which affected Twitter, SoundCloud, Spotify, PayPal, and Box. Dyn posted details about the attack on their website.

Posted Oct 21, 2016 - 09:54 EDT

Resolved
BOX service has been restored. Thank you.
Posted Oct 21, 2016 - 09:46 EDT
Monitoring
Updates are being posted by Dyn, Inc at https://www.dynstatus.com/incidents/nlr4yrr162t8
Posted Oct 21, 2016 - 09:37 EDT
Investigating
At this time BOX is not accessible. We are reaching out to them for further information and an Estimated Time of Repair.
Posted Oct 21, 2016 - 09:18 EDT