Power issues on SAU's main campus
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jun 05, 2021 - 13:59 EDT
Update
Power issues are now resolved, but the WiFi and network in parts of the student center did not come back online after power was restored.
Posted Jun 04, 2021 - 22:02 EDT
Monitoring
All systems seem stable, but SAU IT is monitoring for any additional issues.
Posted Jun 04, 2021 - 18:27 EDT
Update
Power is restored, and most systems are stable at this time. While MySAU is currently up, we do expect it to go down again briefly soon.
Posted Jun 04, 2021 - 17:48 EDT
Investigating
All systems may be impacted by unexpected power loss on SAU's main campus.
Posted Jun 04, 2021 - 16:21 EDT
This incident affected: CARS / MySAU Portal (MySAU Portal) and Spring Arbor Campus (Student Center Network, Campus Power).