Blackboard login issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 13:37 EDT
Monitoring
This issue has been resolved, but if you are still having issues you may need to clear your cache and cookies to resolve the problem permanently.
Posted Oct 19, 2023 - 15:49 EDT
Identified
Blackboard is currently inaccessible if you try to login directly to the website at sauonline.arbor.edu, for now Blackboard can only be accessed through the link on the homepage of MySAU after logging into the MySAU homepage.
Posted Oct 18, 2023 - 10:56 EDT
This incident affected: Blackboard (SAU Online).