Minor Outage - 120 Ogle Street network
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 09, 2019 - 10:04 EST
Investigating
Information Technology is investigating a network outage at 120 Ogle street (University House offices).
Posted 3 months ago. Jan 09, 2019 - 09:35 EST
This incident affected: Spring Arbor Campus (Internet Connectivity).