Phone Issues
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 08:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2024 - 14:22 EDT
Update
SAU's phone service provider has posted an outage and is working on resolving the issue, we will share an update on when this will be resolved when we learn more.
Posted Mar 19, 2024 - 13:26 EDT
Investigating
SAU IT is investigating an outage impacting phone lines on SAU's campus.
Posted Mar 19, 2024 - 13:22 EDT
This incident affected: Voice Phone System.