Physical plant network outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 09:08 EDT
Investigating
IT is investigating a network outage in the physical plant and nursing building.
Posted Jul 10, 2020 - 08:38 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).