Spring Arbor University App
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 14:02 EDT
Investigating
The Spring Arbor University App is unavailable for students or faculty members to log into the application. If you are currently logged into the app, you are able to use the system. We are investigating the issue at this point.
Posted Jul 25, 2023 - 16:42 EDT