Network Outage: Physical Plant
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted 9 days ago. Jul 10, 2019 - 08:11 EDT
Investigating
We are currently investigating this issue.
Posted 10 days ago. Jul 10, 2019 - 07:13 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).