Health Screening App - Outage
Incident Report for Spring Arbor University
Resolved
The Health Screen is back online.
Posted Jun 07, 2021 - 12:24 EDT
Investigating
We are currently investigating an outage with the health screening app.
Posted Jun 07, 2021 - 09:26 EDT
This incident affected: CARS / MySAU Portal (MySAU Portal).