EBSCO library databases

Incident Report for Spring Arbor University

Resolved

This issue has been resolved.
Posted Jun 23, 2025 - 15:13 EDT

Investigating

We are currently investigating an issue with students on and off campus are having issues accessing EBSCO library databases. EBSCO support has been contacted for this issue.
Posted Jun 23, 2025 - 11:16 EDT
This incident affected: Library Journals.