EBSCO host library pages
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 09:08 EDT
Identified
Some users are reporting issues with the EBSCO host pages on the White Library website. The library team is aware of the issue and troubleshooting it now.
Posted Jun 03, 2020 - 14:20 EDT
This incident affected: Blackboard (SAU Online).