Completed
The scheduled maintenance has been completed.
Posted Jul 06, 2026 - 19:15 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 06, 2026 - 17:15 EDT
Scheduled
This scheduled outage is for login services, on campus only. There is a possibility that users logging in to on campus computers may experience disruption. However, any disruption would be brief.
Posted Jul 06, 2026 - 11:58 EDT
This scheduled maintenance affected: Spring Arbor Campus (Internet Connectivity, Printing, 120 Ogle Street Network, Advancement Building Network, Andrews Hall Network, Apartment A Network, Apartment B Network, Apartment C Network, Apartment D Network, Apartment E Network, Apartment F Network, Apartment G Network, Apartment H Network, Art Building Network, CCS House Network, Dietzman Hall Network, Fieldhouse Network, Gainey Hall Network, HR House Network, K House's Networks, Lowell Hall Network, Marketing & Communication House Network, Outdoor Wireless, Poling Center Network, Prop Shop Network, ROTC House Network, Sayre-DeCan Hall (SDH) Network, Smith Music Center (SMC), Soccer Complex Network, Student Center Network, Tennis Complex Network, Vallor House Network, Village A Network, Village B Network, Village C Network, Village D Network, Village E Network, Village F Network, Village G Network, Welcome Center Network, Whiteman-Gibbs Science Center (WG) Network, White Library Network, Campus Power) and Login services.