Box Outage
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 12:49 EST
Identified
Box is currently experiencing a major outage, and is aware of the issue and working to resolve it. At this point their website is unavailable, and Box Drive and Box sync are not loading.
Posted Dec 15, 2023 - 09:58 EST
This incident affected: Box (Box Sync, Box Website, Box Content Preview, Box Mobile, Box Search).