Degraded performance: Single sign on
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Sep 10, 2018 - 21:13 EDT
Update
All service is restored except for access to Box. We are working with the Box team to restore service.
Posted Sep 10, 2018 - 17:14 EDT
Investigating
Information technology is investigating reports of sign in problems with some services
Posted Sep 10, 2018 - 15:38 EDT