Power issues on SAU's campus
Incident Report for Spring Arbor University
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 21:25 EDT
Update
Power has been restored to the Fieldhouse.
Posted Aug 25, 2023 - 20:46 EDT
Identified
The power has been restored to more buildings on campus, but it still unavailable in the Fieldhouse, some of the k-houses, and most of the apartments (all apartments will have no internet until power is restored to all the apartment buildings).
Posted Aug 25, 2023 - 20:18 EDT
This incident affected: Spring Arbor Campus (Internet Connectivity).